October 2010 Archives

Hello World (Movable Type 5 bugs)

Posted on October 16, 2010 3:57 PM in

WordPress site  You can find this post in italian in the archived site lgiustini.wordpress.com.

Image representing Movable Type as depicted in...

Image via CrunchBase

This post started as a simple test entry to understand what's wrong with Movable Type 5.

I use movable Type since it existed and I loved it.

Last week, I installed MT 4.34 over a MT Pro 4.25 installation that resisted for two years without problems (except for a 504 Gateway error when I try to update my Contacts page, ok: I never fixed that since I don't know why does so and how).

Something went wrong: the upgrade process apparently went perfectly, but when I accessed the Dashboard, I discovered the Edit fields (the ones letting you add and edit entries) simply disappeared. Dashboard, interface, settings and so on worked. But when you click on "Create New", you get a simple page where there isn't any text area to put text in.

So I posted some topics to Movable Type Forum to ask help, and Mike, gently as usual, tried to help, but without result. So I decided to try un upgrade to the newest version 5. Again, upgrade went correct, the data was there, but the entry area to update or add entries not.

Finally, discouraged and sad, I did some tests. I tried to copy a fresh copy of MT 5 over that I have on server. And in this phase, something happened: when I call the  mt.cgi, now it called mt-upgrade.cgi procedure and say that:

Time to Upgrade!

The following Movable Type components require upgrading or installation:

* Professional Pack Version 1.53
* Community Pack Version 1.72


But when I click on the Upgrade button, it get stuck and nothing appears, only the dynamic bar (it's a gif....).

Not clear what's wrong, but now I discovered that the problem could rely on the addons/commercial and community packs. So I deleted them from the server and *puf*, the Edit area now appeared! I apparently can use all.

I uploaded the addons dir again, and again, it appeared "Time to Upgrade!" ..

So now, I'm in doubt about what to do. If I upload this "packs" directory onto the server, MT thinks he must upgrade something in that addons. It isn't so (since they come from the latest version of MT!). But If I don't do that, I think something will happen of not specifically good in the future - even if I don't know what....

It's really necessary the directory addons/commercial.pack?

Any hint wil be deeply appreciated!


Enhanced by Zemanta
Welcome 54.225.57.89!
Graduated in Computer science engineering and Information and Communication science (LM-19), I do research on Digital media processes, teaching in higher courses about Communication and New media at the Athenaeum Regina Apostolorum and the University of Tor Vergata. I founded the BETA magazine and the IT News agency; I've been technology visionary for the TEDxViadellaConciliazione, I do consultancy with LG Studio. Contact me, or follow me on Twitter @lucianog!
Social
+

Powered by MailChimp - Articles and selected news.

 

About this Archive

This page is an archive of entries from October 2010 listed from newest to oldest.

April 2009 is the previous archive.

December 2012 is the next archive.

Find recent content on the main index or look in the archives to find all content.

OpenID accepted here Learn more about OpenID